lunes, 16 de noviembre de 2009

Eclipse y Flash : Botones que no funcionan

Parece que hay algun problema con compiz, gnome 2.28 y probablemente nvidia (en mi portatil con grafica intel no hay estos problemas), El problema se da en varios programas (eclipse, flash ....).

1)En el caso de flash, páginas como youtube no responden al stop / play. Y varios botones en general no hacen nada. El problema lo tengo tanto en el escritorio Gnome como en KDE

La solución consiste en desactivar compiz en el escritorio GNOME y KDE. Para ello ejecutamos en el terminal :
simple-ccsm

Esto es equivalente a "Efectos del Escritorio" en el panel de control de gnome. Desmarcamos "enable desktop effect" y todo debería funcionar correctamente en páginas con flash.


2)En el caso de eclipse parece que hay algún problema con la gtk que provoca que algunos botones pierdan el foco. Tambíen desaparecen elementos como cuando vamos a instalar softtware nuevo.

Lo solucionaremos asegurandonos que se exporta la siguiente linea antes de ejecutar eclipse
export GDK_NATIVE_WINDOWS=1
Lo mejor es modificar directamente el ejecutable que lanza eclipse, añadiendo la linea anterior.
Por ejemplo para eclipse instalado manualemente (ver instalar eclipse galileo en opensuse 11.2) realizamos:
sudo cat >> /usr/local/bin/eclipse
#!/bin/sh
export GDK_NATIVE_WINDOWS=true
export ECLIPSE_HOME=/opt/eclipse
$ECLIPSE_HOME/eclipse $*

En el caso de tener la version 3.4 de los repositorios, el ejecutable está en otro lugar. Desde consola usaremos:
whereis eclipse

Y editaremos el ejecutable que aparezca

No hay comentarios: